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Foreword

I  am a comic book superhero.
At least, I play one at work. As the mighty man of macro, I have 

the coolest job in town: playing MrExcel, the smartest guy in the 
world of spreadsheets.

Well, yes, that is a lot of hype. I am not really MrExcel. In fact, there 
are so many different ways to do the same thing in Excel that I am fre-
quently shown up by one of my own students. Of course, I then appropri-
ate that tip and use it as my own!

I have incorporated some of these discoveries in a pretty cool 45-
minute seminar on Power Excel Tips. This is amazing stuff, like pivot 
tables, autofilters, and automatic subtotals. I love to be in front of a 
room full of accountants who use Excel 40+ hours a week and get oohs 
and ahhhs within the first 90 seconds. I have to tell you, if you can make 
a room full of CPAs ooh and ahh, you know that you’ve got some good 
karma going. At that point, I know it will be a laugh-filled session and a 
great 45 minutes.

I also teach a much longer six-hour version of the Power Excel class 
at the University of Akron. This is a hands-on class where everyone gets 
to try each tip on his or her own computer.

One of these classes, which I was presenting at the Greater Akron 
Chamber, provided the Genesis moment for this book. One of the ques-
tions from the audience was about something fairly basic. As I went 
through the explanation, the room was silent as everyone sat in rapt 
attention. People were interested in this basic tip because it was some-
thing that affected their lives every day. It didn’t involve anything cool. 
It was just basic Excel stuff. But, it was basic Excel stuff that a room full 
of pretty bright people had never figured out.

Think about how most of us learned Excel. We started a new job 
where they wanted us to use Excel. They showed us the basics of moving 
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around a spreadsheet and sent us on our way. We were lucky to get five 
minutes of training on the world’s most complex piece of software!

Here is the surprising part of this deal. With only five minutes of 
training, you CAN use Excel 40 hours a week and be productive. Isn’t 
that cool? A tiny bit of training and you can do 80 percent of what you 
need to do in Excel.

The problem, though, is that there are lots of cool things you never 
learned about. Microsoft and Lotus were locked in a bitter battle for 
market share in the mid-90s. In an effort to slay one another, each suc-
ceeding version of Excel or Lotus 1-2-3 offered INCREDIBLY powerful 
new features. This stuff is still lurking in there, but you would never 
know to even look for it. My experience tells me that the average Excel 
user is still doing things the slow way. If you learn a just couple of these 
new tips, you could save two hours per week.

So, here is the plan. I have set out to write a book that talks about 
277 of the most common and irritating problems in Excel. You will find 
each of these 277 items (which you have been stumbling over ever since 
your “five minutes of training”) followed by the solution or solutions you 
need to solve that problem. A lot of these topics stem from the questions 
that were sent my way in seminars I’ve taught. They may not be the 
coolest tips in the whole world, but if you master even half of these con-
cepts, you will be smarter than 95 percent of the Excel users in the world 
and will certainly save yourself several hours per week.

In each chapter, a problem and its solution will be discussed. There 
are plenty of books that go through all of Excel’s menus in a serial fash-
ion. The trouble with those books is that you have NO CLUE what to 
look up when you are having a problem. The last time I checked, no one 
at my dinner table ever used the word “CONCATENATION”, so why 
would anyone ever think of looking up that word when they want to join 
a first name in column A with the last name in column B?

I expect this book will be a quick read. You can probably skim all 277 
topics in a couple of hours to get a basic idea of what is in here. When 
you face a similar situation, find the case study, apply it to your own 
problem, and you should be all set.

This book takes a different approach than others I have tried to use. 
I am MrExcel, but I am hopelessly clueless with PhotoShop. Wow! This 
is an intimidating program. I own a ton of books on PhotoShop. There 
must be a bazillion toolbars in there. Most books that I pick up tell me 
to press the XYZ button on the ABC toolbar. I can’t even begin to figure 
out where that toolbar is. I hate those books. So, my philosophy here is 
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to explain the heck out of things. If you ever find yourself on a case study 
where I tell you to do something without explaining how to do it, please 
send me an e-mail to yell at me for not being clear.

conventions used in the book
Each chapter will start with a problem and then a strategy for solving 
the problem. Various chapters may offer additional details, alternate 
strategies, results, gotchas, and other elements as is appropriate to the 
topic. Each chapter wraps up with a summary and a list of any Excel 
commands or functions used in the chapter.

I hate books where the text refers to a figure that is on the next two 
page spread. In the interest of readability, I’ve chosen to allow white 
space at the bottom of the right-hand page if it will allow the text and 
figure to remain together. This is a conscious decision. I’m not trying to 
pad the page count or increase the cost of paper in the book. I believe 
this layout will maximize the ease of use of the book.
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Show Full MenuS All the tiMe

Problem: You are trying to learn Excel. Microsoft only shows you the 
most common menu choices under each menu. 
Fig. 1 shows a menu from one computer on my desk.

Fig. 2 is a screenshot from another computer on my desk.

Fig. 2

Fig. 1
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A screenshot of the data menu of the third computer on my desk is seen 
here in Fig. 3.

This is maddening. How can you learn that there is a Sort option under 
the Data menu if Excel will not show you all of the options? Furthermore, 
Microsoft customizes the menu on the basis of items you use regularly. 
First, this is insane; you cannot learn to regularly use something if you 
don’t know it is there. Second, when you go to a new computer, one 
of the options that you think should be there may not show up. It is 
very difficult to learn Excel when the menus are not consistent across  
computers.
Strategy: Turn off Adaptive Menus. This will show you the complete 
menu every time that you access that menu. Follow these steps:
1)  Go to the Tools menu, as shown in Fig. 4.

2)  If the Customize option is not shown, select the double-down arrow 
at the bottom of the list in order to expand the menu.

3)  Select Customize… from the Tools menu, as shown in Fig. 5.

Fig. 3

Fig. 4
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4)  As you will see in Fig. 6, there are three tabs across the top of the 
Customize dialog. Choose the Options tab and then choose the box 
for Always Show Full Menus.

Additional Details: If you are in the process of learning Excel, it also 
helps to choose the Show Standard and Formatting Toolbars on Two 
Rows option. This will enable you to see all of the icons on the important 
Standard and Formatting toolbars. In Excel 2000, this setting appears 
as Standard and Formatting Toolbars Share One Row. In that version, 
you will want to uncheck the option.
Gotcha: Changing this setting in Excel will also affect Word and other 
Office products. There is no way to have Excel show full menus while 
Word shows the abbreviated menus.
Summary: While learning Excel, use the Tools – Customize feature to 
show the complete list of commands on each menu.
Commands Discussed: Tools – Customize

Fig. 5

Fig. 6
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Show Full toolbArS All the tiMe

Problem: You are trying to learn Excel. By default, Microsoft only 
shows you the most common menu choices from Excel’s two most impor-
tant toolbars: Standard and Formatting. 
The Standard toolbar has icons for a New Workbook, Saving, Printing, 
Print Preview, Spell Check, Cut, Copy, Paste, Undo, and Redo. These 
are all fairly important items.
The Formatting toolbar has icons for Font, Font Size, Bold, Italic, Un-
derline, Left Align, Center, Right Align, Number, Bullets, Indent, Out-
dent, Borders, Cell Color, and Font Color. These are also all fairly im-
portant items.
The complete Standard toolbar can be seen here in Fig. 7. Note that my 
toolbar has some extra icons from various add-ins that I use.

Although this is the complete toolbar, most default installations will 
only show a subset of the icons on the toolbar. An example of the abbre-
viated toolbar follows in Fig. 8.

In order to use any of the other icons on the Standard toolbar, you have 
to choose the double-right arrow on the toolbar, as shown in Fig. 9.

Fig. 7

Fig. 8

Fig. 9
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The complete Formatting toolbar follows in Fig. 10.

Most users with a default installation will only see a portion of these 
icons and will have to use the double-right arrow on the toolbar to see 
all of the icons.
Microsoft does this in order to show you more rows of data in the spread-
sheet. This may have been a problem in the days of VGA monitors. How-
ever, with today’s high screen resolutions, you can afford to have the 
toolbars displayed on two rows and to see all of the available options at 
a glance.
Strategy: Display the toolbars on two rows. From the Tools menu, se-
lect Customize. On the Options tab, select the option for Show Standard 
and Formatting toolbars on two rows, as shown in Fig. 11.

Gotcha: In Excel 2000 and earlier, this option was called Display Stan-
dard and Formatting Toolbars on One Row.
Summary: While learning Excel, use the Tools – Customize feature to 
show the complete version of Standard and Formatting toolbars.
Commands Discussed: Tools – Customize

Fig. 10

Fig. 11
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Add A CloSe button  
to the StAndArd toolbAr

Problem: Your efficiency with Excel would increase if you had a one-
click option for closing workbooks.
Strategy: Customize the Standard toolbar to include a Close option 
near the Save option. Follow these steps.
1) From the menu, select View – Toolbars – Customize. The Custom-

ize option is the final choice in the list of toolbars. This will display 
the Customize dialog box. 

 While the Customize box is displayed, the toolbars are in a special 
state. You can take any toolbar button and drag it to a new location, 
to a new toolbar, or even drag it off the toolbar to delete it. Also, 
there are hundreds of new icons that you can add to your toolbars. 

2) From the Customize dialog box, choose the Commands tab, as 
shown in Fig. 12. 

3) Choose a Category in the left listbox. From the right listbox, you 
can scroll through dozens of buttons in that category.

Fig. 12
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4) The Close button is located in the File category. Choose File from 
the left listbox, as shown in Fig. 13.

5) Click on Close in the right listbox. Drag the item towards a toolbar. 
When you are on the toolbar, choose the desired location. Excel will 
display an I-Beam at the location where the button will be added, 
as shown in Fig. 14.

Fig. 13

Fig. 14
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6) When the I-Beam is in the proper location, release the mouse but-
ton. The button is added to the toolbar, as shown in Fig. 15.

7) Choose OK to close the Customize dialog. The Close button will re-
main on your Standard toolbar in this and all future Excel sessions 
until you remove it.

Summary: Experiment with adding new buttons so that any task that 
you perform regularly has a one-click option.
Commands Discussed: View – Toolbars – Customize

CloSe All open workbookS

Problem: You have 22 Excel workbooks open. You want to keep Excel 
open but close all of the workbooks. Doing File – Close 22 times can get 
monotonous.
Strategy: Hold down the Shift key on 
the keyboard before selecting the File 
menu. This will allow you to see an 
alternate File menu with Close All in 
place of Close, as shown in Fig. 16.
Summary: Hold down the Shift key 
to access the timesaving Close All 
command. 
Commands Discussed: File – Close 
All

Fig. 15

Fig. 16
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